: How to install avs sdk in old stable ubuntu / aws

https://developer.amazon.com/en-US/docs/alexa/avs-device-sdk/linux.html

sudo apt-get update

sudo apt-get install git gcc cmake openssl clang-format-3.4 libgstreamer1.0-dev
sudo apt-get install git gcc cmake openssl clang-format-3.4 libgstreamer1.0-dev
#sudo apt-get install git gcc cmake3 openssl clang-format-3.9 libgstreamer1.0-dev
#cmake –version check cmake 2 or cmake 3
#sudo apt-get install git gcc cmake3 openssl clang-format-3.8 libgstreamer1.0-dev
sudo apt-get install libgstreamer-plugins-good1.0-dev libgstreamer-plugins-bad1.0-dev
sudo apt-get install libgstreamer-plugins-base1.0-dev gstreamer1.0-plugins-good
sudo apt-get install libgstreamer-plugins-good1.0-dev libgstreamer-plugins-bad1.0-dev
sudo apt-get install gstreamer1.0-libav pulseaudio doxygen libsqlite3-dev libasound2-dev
sudo apt-get install repo

$ mkdir -p ~/.bin
$ PATH=”${HOME}/.bin:${PATH}”
$ curl https://storage.googleapis.com/git-repo-downloads/repo > ~/.bin/repo
$ chmod a+rx ~/.bin/repo

#cmake $HOME/my_project/source/avs-device-sdk

sudo apt-get install gstreamer1.0-plugins-base-apps

sudo apt-get install gstreamer1.0-plugins-bad
sudo apt-get install gstreamer1.0-plugins-ugly
cmake $HOME/my_project/source/avs-device-sdk -DGSTREAMER_MEDIA_PLAYER=ON

frozenberg commented on 31 Jan 2018
Ok, thanks for the reply. It looks like gstreamer is being installed somewhere that the SDK isn’t looking.

Can you see if this directory exists?
/usr/local/Cellar/gstreamer

Can you paste the contents of that directory if it does exist?

Fede

gst-inspect-1.0 –version
gst-inspect-1.0 –version
gst-inspect-1.0 version 1.2.4
GStreamer 1.2.4

livcuel 4

sudo apt-get install libcurl4-openssl-dev
sudo apt-get install libssl-dev

Leave a Reply

メールアドレスが公開されることはありません。

注意(NOTICE)

コメントの投稿は反映までに時間がかかる場合があります。 Post Comments may take some minutes to publish.